<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi | Mtanzania</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://mtanzania.co.tz/xmlrpc.php" />
    <meta property="og:image" content="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mtanzania &raquo; Feed" href="https://mtanzania.co.tz/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mtanzania &raquo; Comments Feed" href="https://mtanzania.co.tz/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mtanzania &raquo; MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi Comments Feed" href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mtanzania.co.tz\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://mtanzania.co.tz/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-newsletter-css'  href='https://mtanzania.co.tz/wp-content/plugins/td-newsletter/style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://mtanzania.co.tz/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=3593e6198288cd1f8b28dc83dd3b8ada' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://mtanzania.co.tz/wp-content/themes/newspaper/Newspaper/style.css?ver=8.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://mtanzania.co.tz/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=b750612463a242d669bd59c5cf49d705' type='text/css' media='all' />
<script type='text/javascript' src='https://mtanzania.co.tz/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://mtanzania.co.tz/wp-json/" /><link rel="alternate" type="application/json" href="https://mtanzania.co.tz/wp-json/wp/v2/posts/102428" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mtanzania.co.tz/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mtanzania.co.tz/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel="canonical" href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/" />
<link rel='shortlink' href='https://mtanzania.co.tz/?p=102428' />
<link rel="alternate" type="application/json+oembed" href="https://mtanzania.co.tz/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mtanzania.co.tz/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.15 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/mtanzania.co.tz\/wp-admin\/","wpRestNonce":"819d74c9e8","wpRestUrl":"https:\/\/mtanzania.co.tz\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <link rel="amphtml" href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/amp/">
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-126045841-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-126045841-1');
</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://mtanzania.co.tz/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://mtanzania.co.tz/category/afya/",
                                "name": "Afya na Jamii"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/",
                                "name": "MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi"                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://mtanzania.co.tz/wp-content/uploads/2017/03/cropped-Z-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mtanzania.co.tz/wp-content/uploads/2017/03/cropped-Z-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mtanzania.co.tz/wp-content/uploads/2017/03/cropped-Z-180x180.png" />
<meta name="msapplication-TileImage" content="https://mtanzania.co.tz/wp-content/uploads/2017/03/cropped-Z-270x270.png" />

<!-- Button style compiled by theme -->

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #db021b;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #db021b;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #db021b;
                }
                .tdm-btn-style1 {
					background-color: #db021b;
				}
				.tdm-btn-style2:before {
				    border-color: #db021b;
				}
				.tdm-btn-style2 {
				    color: #db021b;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #db021b;
                    -moz-box-shadow: 0 2px 16px #db021b;
                    box-shadow: 0 2px 16px #db021b;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #db021b;
                    -moz-box-shadow: 0 4px 26px #db021b;
                    box-shadow: 0 4px 26px #db021b;
				}
</style>

	<style id="tdw-css-placeholder"></style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-8978810860331221",
          enable_page_level_ads: true
     });
</script>
	
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/77344670/MTZ_Home_728x90_1', [728, 90], 'div-gpt-ad-1610018126278-0').addService(googletag.pubads());
	googletag.defineSlot('/77344670/MTZ_HOME-300x250_1', [300, 250], 'div-gpt-ad-1610615662330-0').addService(googletag.pubads());
	googletag.defineSlot('/77344670/MTZ_HOME_300x250_2', [300, 250], 'div-gpt-ad-1610630649759-0').addService(googletag.pubads());
	googletag.defineSlot('/77344670/MTZ-HOME-728x250_1', [[970, 90], [728, 90], [728, 250]], 'div-gpt-ad-1610713738274-0').addService(googletag.pubads());
	googletag.defineSlot('/77344670/MTZ_article_728x90_1', [728, 90], 'div-gpt-ad-1610715033371-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
	
</script>

	
	<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
var _avp = _avp || [];
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript'; s.async = true; s.src = window.location.protocol + '//betnetmed.advertserve.com/js/libcode3.js';
  var x = document.getElementsByTagName('script')[0];
  x.parentNode.insertBefore(s, x);
})();
</script>
<!-- END ADVERTSERVE CODE -->  
<script src="https://cdn.gravitec.net/storage/77b03290f60bf2579f61c989443ca2a8/client.js" async></script>
	
</head>

<body class="post-template-default single single-post postid-102428 single-format-standard makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/mtanzanianews" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/mtanzanianews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCyUoC43pwXFJo0itXbuVjJQ" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-mtz-header-menu-container"><ul id="menu-mtz-header-menu" class="td-mobile-main-menu"><li id="menu-item-78651" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-78651"><a href="https://mtanzania.co.tz/">mwanzo</a></li>
<li id="menu-item-59959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59959"><a href="#">burudani</a></li>
<li id="menu-item-59960" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59960"><a href="#">makala</a></li>
<li id="menu-item-59961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59961"><a href="#">michezo<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://mtanzania.co.tz/category/michezo/michezo-kimataifa/">Michezo Kimataifa</a></li>
	<li class="menu-item-0"><a href="https://mtanzania.co.tz/category/michezo/michezo-kitaifa/">Michezo Kitaifa</a></li>
</ul>
</li>
<li id="menu-item-59962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59962"><a href="#">video</a></li>
<li id="menu-item-59963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59963"><a href="#">categories</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://mtanzania.co.tz/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 3
-->


<div class="td-header-wrap td-header-style-3 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-4" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-4"><a href="http://mtanzania.co.tz/">Mwanzo</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7"><a href="https://mtanzania.co.tz/category/kitaifa/">Kitaifa</a></li>
<li id="menu-item-6" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6"><a href="https://mtanzania.co.tz/category/kimataifa/">Kimataifa</a></li>
<li id="menu-item-8" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-8"><a href="https://mtanzania.co.tz/category/mikoani/">Mikoani</a>
<ul class="sub-menu">
	<li id="menu-item-5" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-5"><a href="https://mtanzania.co.tz/category/kanda-ya-ziwa-2/">Kanda ya Ziwa</a></li>
</ul>
</li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-33"><a href="https://mtanzania.co.tz/category/zanzibar/">Zanzibar</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39"><a href="https://mtanzania.co.tz/category/siasa/">Siasa</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-40"><a href="https://mtanzania.co.tz/category/uchumi/">Biashara na Uchumi</a></li>
<li id="menu-item-35198" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-35198"><a href="https://mtanzania.co.tz/category/afya/">Afya na Jamii</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://mtanzania.co.tz/category/sanaa/">Burudani</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-36"><a href="https://mtanzania.co.tz/category/michezo/">Michezo</a>
<ul class="sub-menu">
	<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-37"><a href="https://mtanzania.co.tz/category/michezo/michezo-kimataifa/">Michezo Kimataifa</a></li>
	<li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38"><a href="https://mtanzania.co.tz/category/michezo/michezo-kitaifa/">Michezo Kitaifa</a></li>
</ul>
</li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-banner-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                            <a class="td-main-logo" href="https://mtanzania.co.tz/">
                <img src="https://mtanzania.co.tz/wp-content/uploads/2020/06/Header_Logo_Black.png" alt=""/>
                <span class="td-visual-hidden">Mtanzania</span>
            </a>
                    </div>
                            <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_603abad7aaa49_rand td_block_template_1"><!-- /77344670/MTZ_Home_728x90_1 -->
<div id='div-gpt-ad-1610018126278-0' style='width: 728px; height: 90px;'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1610018126278-0');
</script>
</div></div>
</div>                </div>
                    </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-disable" href="https://mtanzania.co.tz/">
			<img src="https://mtanzania.co.tz/wp-content/uploads/2020/06/footer_logo-300x57.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://mtanzania.co.tz/">
			<img src="https://mtanzania.co.tz/wp-content/uploads/2020/06/Header_Logo_Black.png" alt=""/>
		</a>
	    </div>
    <div class="menu-mtz-header-menu-container"><ul id="menu-mtz-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-78651"><a href="https://mtanzania.co.tz/">mwanzo</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu menu-item-59959"><a href="#">burudani</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_603abad7ab40f_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_2_603abad7ab40f" ><script>var block_td_uid_2_603abad7ab40f = new tdBlock();
block_td_uid_2_603abad7ab40f.id = "td_uid_2_603abad7ab40f";
block_td_uid_2_603abad7ab40f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"35","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_603abad7ab40f_rand","tdc_css_class":"td_uid_2_603abad7ab40f_rand","tdc_css_class_style":"td_uid_2_603abad7ab40f_rand_style"}';
block_td_uid_2_603abad7ab40f.td_column_number = "3";
block_td_uid_2_603abad7ab40f.block_type = "td_block_mega_menu";
block_td_uid_2_603abad7ab40f.post_count = "5";
block_td_uid_2_603abad7ab40f.found_posts = "2744";
block_td_uid_2_603abad7ab40f.header_color = "";
block_td_uid_2_603abad7ab40f.ajax_pagination_infinite_stop = "";
block_td_uid_2_603abad7ab40f.max_num_pages = "549";
tdBlocksArray.push(block_td_uid_2_603abad7ab40f);
</script><div id=td_uid_2_603abad7ab40f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/desclo-james-w-smelo-waiweka-wazi-pasola-mbese/" rel="bookmark" class="td-image-wrap" title="Desclo James W, SMELO waiweka wazi &#8216;Pasola Mbese&#8217;"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0046-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0046-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0046-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Desclo James W, SMELO waiweka wazi &#8216;Pasola Mbese&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/desclo-james-w-smelo-waiweka-wazi-pasola-mbese/" rel="bookmark" title="Desclo James W, SMELO waiweka wazi &#8216;Pasola Mbese&#8217;">Desclo James W, SMELO waiweka wazi &#8216;Pasola Mbese&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/tunecore-yatua-kwa-kishindo-afrika-mashariki/" rel="bookmark" class="td-image-wrap" title="TuneCore yatua kwa kishindo Afrika Mashariki"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0037-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0037-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0037-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="TuneCore yatua kwa kishindo Afrika Mashariki"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/tunecore-yatua-kwa-kishindo-afrika-mashariki/" rel="bookmark" title="TuneCore yatua kwa kishindo Afrika Mashariki">TuneCore yatua kwa kishindo Afrika Mashariki</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/kelvin-kay-wa-ghana-aitaja-yanga-awazimia-diamond-harmonize-rayvanny/" rel="bookmark" class="td-image-wrap" title="Kelvin Kay wa Ghana aitaja &#8216;Yanga&#8217;, awazimia Diamond, Harmonize, Rayvanny"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0005-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0005-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210226-WA0005-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kelvin Kay wa Ghana aitaja &#8216;Yanga&#8217;, awazimia Diamond, Harmonize, Rayvanny"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/kelvin-kay-wa-ghana-aitaja-yanga-awazimia-diamond-harmonize-rayvanny/" rel="bookmark" title="Kelvin Kay wa Ghana aitaja &#8216;Yanga&#8217;, awazimia Diamond, Harmonize, Rayvanny">Kelvin Kay wa Ghana aitaja &#8216;Yanga&#8217;, awazimia Diamond, Harmonize, Rayvanny</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/rastabwoykell-asimulia-polisi-walivyofanya-awe-mwanamuziki/" rel="bookmark" class="td-image-wrap" title="Makala: Rastabwoykell asimulia polisi walivyofanya awe mwanamuziki"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210224-WA0047-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210224-WA0047-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210224-WA0047-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Makala: Rastabwoykell asimulia polisi walivyofanya awe mwanamuziki"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/rastabwoykell-asimulia-polisi-walivyofanya-awe-mwanamuziki/" rel="bookmark" title="Makala: Rastabwoykell asimulia polisi walivyofanya awe mwanamuziki">Makala: Rastabwoykell asimulia polisi walivyofanya awe mwanamuziki</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/mastaa-bongo-wahimizwa-kuvaa-mavazi-ya-kiafrika/" rel="bookmark" class="td-image-wrap" title="Mastaa Bongo wahimizwa kuvaa mavazi ya Kiafrika"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210221-WA0091-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210221-WA0091-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210221-WA0091-100x70.jpg 100w, https://mtanzania.co.tz/wp-content/uploads/2021/02/IMG-20210221-WA0091-713x486.jpg 713w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Mastaa Bongo wahimizwa kuvaa mavazi ya Kiafrika"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/mastaa-bongo-wahimizwa-kuvaa-mavazi-ya-kiafrika/" rel="bookmark" title="Mastaa Bongo wahimizwa kuvaa mavazi ya Kiafrika">Mastaa Bongo wahimizwa kuvaa mavazi ya Kiafrika</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_603abad7ab40f" data-td_block_id="td_uid_2_603abad7ab40f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_603abad7ab40f" data-td_block_id="td_uid_2_603abad7ab40f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu menu-item-59960"><a href="#">makala</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_603abad7b2015_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_3_603abad7b2015" ><script>var block_td_uid_3_603abad7b2015 = new tdBlock();
block_td_uid_3_603abad7b2015.id = "td_uid_3_603abad7b2015";
block_td_uid_3_603abad7b2015.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"7","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_3_603abad7b2015_rand","tdc_css_class":"td_uid_3_603abad7b2015_rand","tdc_css_class_style":"td_uid_3_603abad7b2015_rand_style"}';
block_td_uid_3_603abad7b2015.td_column_number = "3";
block_td_uid_3_603abad7b2015.block_type = "td_block_mega_menu";
block_td_uid_3_603abad7b2015.post_count = "5";
block_td_uid_3_603abad7b2015.found_posts = "2252";
block_td_uid_3_603abad7b2015.header_color = "";
block_td_uid_3_603abad7b2015.ajax_pagination_infinite_stop = "";
block_td_uid_3_603abad7b2015.max_num_pages = "451";
tdBlocksArray.push(block_td_uid_3_603abad7b2015);
</script><div id=td_uid_3_603abad7b2015 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/" rel="bookmark" class="td-image-wrap" title="MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/" rel="bookmark" title="MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi">MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/makala-ujenzi-wa-kiwanda-cha-alizeti-kwainua-uchumi-wa-wananchi-hanang/" rel="bookmark" class="td-image-wrap" title="Ujenzi wa kiwanda cha alizeti kwainua uchumi wa wananchi Hanan&#8217;g"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/e705654b-6b23-4a17-b3df-16c1cc49915a-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/e705654b-6b23-4a17-b3df-16c1cc49915a-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/e705654b-6b23-4a17-b3df-16c1cc49915a-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Ujenzi wa kiwanda cha alizeti kwainua uchumi wa wananchi Hanan&#8217;g"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/makala-ujenzi-wa-kiwanda-cha-alizeti-kwainua-uchumi-wa-wananchi-hanang/" rel="bookmark" title="Ujenzi wa kiwanda cha alizeti kwainua uchumi wa wananchi Hanan&#8217;g">Ujenzi wa kiwanda cha alizeti kwainua uchumi wa wananchi Hanan&#8217;g</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/makala-familia-ya-wasioona-waomba-msaada-wa-elimu-mashine/" rel="bookmark" class="td-image-wrap" title="Makala: Familia ya wasioona waomba msaada wa elimu, mashine"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/aa0d76c7-0313-4ec5-8846-6c9655cafe53-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/aa0d76c7-0313-4ec5-8846-6c9655cafe53-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/aa0d76c7-0313-4ec5-8846-6c9655cafe53-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Makala: Familia ya wasioona waomba msaada wa elimu, mashine"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/makala-familia-ya-wasioona-waomba-msaada-wa-elimu-mashine/" rel="bookmark" title="Makala: Familia ya wasioona waomba msaada wa elimu, mashine">Makala: Familia ya wasioona waomba msaada wa elimu, mashine</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/makala-ufuatiliaji-na-utekelezaji-umedhibiti-bidhaa-zisizotakiwa-tmda-kanda-ya-ziwa/" rel="bookmark" class="td-image-wrap" title="Makala: Ufuatiliaji na uteketezaji umedhibiti bidhaa zisizotakiwa Kanda ya Ziwa"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/873e6dde-42ba-4ad1-a04c-8097988c32cb-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/873e6dde-42ba-4ad1-a04c-8097988c32cb-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/873e6dde-42ba-4ad1-a04c-8097988c32cb-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Makala: Ufuatiliaji na uteketezaji umedhibiti bidhaa zisizotakiwa Kanda ya Ziwa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/makala-ufuatiliaji-na-utekelezaji-umedhibiti-bidhaa-zisizotakiwa-tmda-kanda-ya-ziwa/" rel="bookmark" title="Makala: Ufuatiliaji na uteketezaji umedhibiti bidhaa zisizotakiwa Kanda ya Ziwa">Makala: Ufuatiliaji na uteketezaji umedhibiti bidhaa zisizotakiwa Kanda ya Ziwa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/makala-microbiolojia-uoteshaji-vimelea-vya-magonjwa-unavyofanikisha-uchunguzi-wa-dawa-na-vipukusi-2/" rel="bookmark" class="td-image-wrap" title="Makala: ‘MICROBIOLOJIA’ uoteshaji vimelea vya magonjwa unavyofanikisha uchunguzi wa dawa na vipukusi-2"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/c2e01365-e653-4932-821b-7abd040840b0-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/c2e01365-e653-4932-821b-7abd040840b0-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/c2e01365-e653-4932-821b-7abd040840b0-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Makala: ‘MICROBIOLOJIA’ uoteshaji vimelea vya magonjwa unavyofanikisha uchunguzi wa dawa na vipukusi-2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/makala-microbiolojia-uoteshaji-vimelea-vya-magonjwa-unavyofanikisha-uchunguzi-wa-dawa-na-vipukusi-2/" rel="bookmark" title="Makala: ‘MICROBIOLOJIA’ uoteshaji vimelea vya magonjwa unavyofanikisha uchunguzi wa dawa na vipukusi-2">Makala: ‘MICROBIOLOJIA’ uoteshaji vimelea vya magonjwa unavyofanikisha uchunguzi wa dawa na&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_603abad7b2015" data-td_block_id="td_uid_3_603abad7b2015"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_603abad7b2015" data-td_block_id="td_uid_3_603abad7b2015"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu menu-item-59961"><a href="#">michezo</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_603abad7b7f4b_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_4_603abad7b7f4b" ><script>var block_td_uid_4_603abad7b7f4b = new tdBlock();
block_td_uid_4_603abad7b7f4b.id = "td_uid_4_603abad7b7f4b";
block_td_uid_4_603abad7b7f4b.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"8","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_4_603abad7b7f4b_rand","tdc_css_class":"td_uid_4_603abad7b7f4b_rand","tdc_css_class_style":"td_uid_4_603abad7b7f4b_rand_style"}';
block_td_uid_4_603abad7b7f4b.td_column_number = "3";
block_td_uid_4_603abad7b7f4b.block_type = "td_block_mega_menu";
block_td_uid_4_603abad7b7f4b.post_count = "4";
block_td_uid_4_603abad7b7f4b.found_posts = "3271";
block_td_uid_4_603abad7b7f4b.header_color = "";
block_td_uid_4_603abad7b7f4b.ajax_pagination_infinite_stop = "";
block_td_uid_4_603abad7b7f4b.max_num_pages = "818";
tdBlocksArray.push(block_td_uid_4_603abad7b7f4b);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_603abad7b7f4b" id="td_uid_5_603abad7bfa3a" data-td_block_id="td_uid_4_603abad7b7f4b" data-td_filter_value="" href="https://mtanzania.co.tz/category/michezo/">All</a><a class="mega-menu-sub-cat-td_uid_4_603abad7b7f4b"  id="td_uid_6_603abad7bfa68" data-td_block_id="td_uid_4_603abad7b7f4b" data-td_filter_value="10" href="https://mtanzania.co.tz/category/michezo/michezo-kimataifa/">Michezo Kimataifa</a><a class="mega-menu-sub-cat-td_uid_4_603abad7b7f4b"  id="td_uid_7_603abad7bfa9a" data-td_block_id="td_uid_4_603abad7b7f4b" data-td_filter_value="9" href="https://mtanzania.co.tz/category/michezo/michezo-kitaifa/">Michezo Kitaifa</a></div></div><div id=td_uid_4_603abad7b7f4b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/hatujapokea-barua-rasmi-ushiki-wa-kenya-kili-marathon-baya/" rel="bookmark" class="td-image-wrap" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/hatujapokea-barua-rasmi-ushiki-wa-kenya-kili-marathon-baya/" rel="bookmark" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo">Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/tujapokea-barua-rasmi-ushiki-wa-kenya-kili-marathon-baya/" rel="bookmark" class="td-image-wrap" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/7ec7bf8f8eee44d53834253747f0a520-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/tujapokea-barua-rasmi-ushiki-wa-kenya-kili-marathon-baya/" rel="bookmark" title="Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo">Hatujapokea barua rasmi ushiki wa Kenya Kili Marathon-Bayo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/umsota-kuongeza-wanachama/" rel="bookmark" class="td-image-wrap" title="Umsota kuongeza wanachama"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/98882906-3ddc-4e9f-9a7d-76dd7cfebea2-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/98882906-3ddc-4e9f-9a7d-76dd7cfebea2-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/98882906-3ddc-4e9f-9a7d-76dd7cfebea2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Umsota kuongeza wanachama"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/umsota-kuongeza-wanachama/" rel="bookmark" title="Umsota kuongeza wanachama">Umsota kuongeza wanachama</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/walimu-wapigia-hesabu-pointi-za-abc/" rel="bookmark" class="td-image-wrap" title="Walimu wapigia hesabu pointi za ABC"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/dfe40b2e-e4b5-4c65-976a-10e02ebca3dd-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/dfe40b2e-e4b5-4c65-976a-10e02ebca3dd-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/dfe40b2e-e4b5-4c65-976a-10e02ebca3dd-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Walimu wapigia hesabu pointi za ABC"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/walimu-wapigia-hesabu-pointi-za-abc/" rel="bookmark" title="Walimu wapigia hesabu pointi za ABC">Walimu wapigia hesabu pointi za ABC</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_603abad7b7f4b" data-td_block_id="td_uid_4_603abad7b7f4b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_603abad7b7f4b" data-td_block_id="td_uid_4_603abad7b7f4b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-59962"><a href="#">video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-59963"><a href="#">categories</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://mtanzania.co.tz/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://mtanzania.co.tz/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Afya na Jamii" class="entry-crumb" href="https://mtanzania.co.tz/category/afya/">Afya na Jamii</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-102428" class="post-102428 post type-post status-publish format-standard has-post-thumbnail hentry category-afya category-featured category-makala" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://mtanzania.co.tz/category/afya/">Afya na Jamii</a></li><li class="entry-category"><a  href="https://mtanzania.co.tz/category/makala/">Makala</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://mtanzania.co.tz/author/newhabari/">Mtanzania Digital</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-27T14:08:55+00:00" >February 27, 2021</time></span>                    <div class="td-post-comments"><a href="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-102428">161</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=MAKALA%3A+Zifahamu+njia+za+Uzazi+wa+Mpango+zinavyofanyakazi&url=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F&via=Mtanzania">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/&amp;media=https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg&description=MAKALA%3A+Zifahamu+njia+za+Uzazi+wa+Mpango+zinavyofanyakazi">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi %0A%0A https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/&text=MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi">
                                        <div class="td-social-but-icon"><i class="td-icon-telegram"></i></div>
                                        <div class="td-social-but-text">Telegram</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg" data-caption=""><img width="560" height="340" class="entry-thumb td-modal-image" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg 560w, https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13-300x182.jpg 300w" sizes="(max-width: 560px) 100vw, 560px" alt="" title="0-13"/></a></div>
        
<p><br><strong><em>Na Yohana Paul, Mwanza</em></strong></p>



<p>KWA mjibu wa Shirika la Afya Duniani (WHO), iliyotolewa juni 2020 takribani wanawake bilioni 1.9 walio katika Umri wa Uzazi (miaka 15-49) ulimwenguni kote mnamo 2019, bilioni 1.1 kati yao wana hitaji la uzazi wa mpango.</p>



<figure class="wp-block-image size-large"><img loading="lazy" width="685" height="336" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/a.jpg" alt="" class="wp-image-102440" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/a.jpg 685w, https://mtanzania.co.tz/wp-content/uploads/2021/02/a-300x147.jpg 300w, https://mtanzania.co.tz/wp-content/uploads/2021/02/a-324x160.jpg 324w, https://mtanzania.co.tz/wp-content/uploads/2021/02/a-533x261.jpg 533w" sizes="(max-width: 685px) 100vw, 685px" /></figure>



<p>Kati ya hao, milioni 842 wanatumia njia za uzazi wa mpango, huku milioni 270 bado wana uhitaji wa uzazi wa mpango ili kupanga na kuamua idadi na nafasi ya watoto wao.</p>



<p>Matumizi ya uzazi wa mpango huzuia ujauzito kwa wanawake, haswa kwa wasichana, ambapo inatoa faida mbali mbali za kiafya ambazo zinajumuisha fursa za elimu zilizopanuliwa na uwezeshwaji kwa wanawake, na ukuaji endelevu wa idadi ya watu na maendeleo ya uchumi kwa nchi.</p>



<p>WHO wanasema matumizi ya kisasa ya uzazi wa mpango kati ya wanawake walioolewa wa umri wa kuzaa (MWRA) iliongezeka ulimwenguni kati ya mwaka 2000 na 2019 kwa asilimia 2.1 kutoka asilimia 55.0 hadi 57.1.</p>



<p>Inaelezwa kuwa sababu zinazopelekea ongezeko hilo dogo tofauti na matarajio ni pamoja na: uchaguzi mdogo wa njia, upatikanaji mdogo wa huduma, haswa kati ya vijana, masikini na watu wasioolewa, hofu au uzoefu wa athari mbaya.</p>



<figure class="wp-block-image size-large"><img loading="lazy" width="605" height="375" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/aa.gif" alt="" class="wp-image-102441" /></figure>



<p>Pia zipo sababu za upinzani wa kitamaduni au kidini; ubora duni wa huduma zinazopatikana; upendeleo wa watumiaji na watoa huduma dhidi ya njia zingine; na vizuizi vya kijinsia vya kupata huduma.</p>



<p>Njia za kisasa za uzazi wa mpango ni pamoja na vidonge vya uzazi wa mpango vya mdomo, vipandikizi, sindano, viraka, pete za uke, vifaa vya ndani ya uterine, kondomu, kuzaa kwa wanaume na wanawake, njia za kukomesha kunyonyesha, njia za kujiondoa na ufahamu wa uzazi. <br>Njia hizi zina utofauti wa utekelezaji na ufanisi katika kuzuia ujauzito</p>



<p>usiotarajiwa ambapo ufanisi wa njia hupimwa na idadi ya ujauzito kwa wanawake 100 wanaotumia njia hiyo kwa mwaka. </p>



<p>Kwa mjibu wa tafiti za kisayansi, uzazi wa mpango wa mdomo (COCs) &#8220;kidonge&#8221; hii huzuia kutolewa kwa mayai kutoka kwa ovari (ovulation) ambapo vidonge vyenye projestojeni tu (POPs) au &#8220;kibonge&#8221; huzidisha ute wa kizazi kuzuia manii na yai kukutana na kuzuia mayai kutolewa.</p>



<p>Pia utumiaji wa dawa za sindano za Projestojeni hutengeneza ute wa kizazi kuzuia manii na yai kukutana na kuzuia mayai kutolewa ambapo sindano za kila mwezi au uzazi wa mpango wa sindano uliochanganywa pia husadia kuzuia kutolewa kwa mayai kutoka kwa ovari.</p>



<p>Aidha njia ya kitambaa cha uzazi wa mpango kilichojumuishwa na pete ya uke ya uzazi wa mpango nayo pia inazuia kutolewa kwa mayai kutoka kwa ovari (ovulation) kwa kiraka na hivyo kushindwa kukutana na manii ambayo yangefanya uchavuchaji wenye kupelekea kitungwa kwa mimba.</p>



<p>Njia nyingine ni utumiaji wa kifaa cha ndani (IUD): hapa unaweza kutumia shaba iliyo na sehemu ya Shaba ambayo huharibu manii na kuizuia kukutana na yai na pia Kifaa cha intrauterine (IUD) ambacho nacho hunenepesha ute wa kizazi na kuzuia manii na yai kukutana.</p>



<figure class="wp-block-image size-large"><img loading="lazy" width="560" height="340" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg" alt="" class="wp-image-102442" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg 560w, https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13-300x182.jpg 300w" sizes="(max-width: 560px) 100vw, 560px" /></figure>



<p>Njia ya Kondomu ambayo hutumiwa zaidi na vijana wengi kutokana na urahisi wa matumizi, hii hujumuisha kondomu za kiume ambayo hufanya kizuizi kuzuia manii na yai kukutana na pia zipo kondomu za kike ambazo nazo hufanya kizuizi kuzuia manii na yai kukutana Kupunguza kuzaa.</p>



<p>Njia ya joto la msingi (BBT) hizi huzuia ujauzito kwa kujiepusha na ngono ya uke bila kinga wakati wa siku nyingi za rutuba kwa kuangalia kiwango cha joto la mwanamke ambalo hukadiriwa kama kiashiria cha siku hatarishi.</p>



<p>Pia inawezekana kupanga uzazi kwa kutumia vidonge vya uzazi wa mpango vya dharura ambavyo vinazuia au kuchelewesha kutolewa kwa mayai kutoka kwa ovari, ambapo vidonge vilivyochukuliwa huzuia ujauzito hadi siku 5 baada ya kujamiiana bila kinga.</p>



<p>Njia nyingine ambayo inahitaji uelewa sahihi wa mzunguko wa hedhi ni njia ya kalenda, ambapo wanandoa ama wapenzi walio katika mahusiano huzuia ujauzito kwa kujiepusha na ngono bila kinga wakati wa siku hatarishi za uwezekano wa kutungwa mimba kwa kuacha au kutumia kondomu.</p>



<p>Aidha ipo njia ya kuondoa (coitus interruptus), ambapo mwanaume huweka manii nje ya mwili wa mwanamke na kuzuia mbolea kwenda kufanya uchavushaji kwenye mayai ya mwanamke, njii hii ni ngumu kutokana na uwezekana mdogo wa wanaume wengi kustahimili kuitekeleza wakati wa tendo.</p>



<p>Mbali na uwepo wa njia tofauti zinazotumika kupanga uzazi, wataalamu wa afya wanashauri ili kufikia lengo la kupanga watoto ni vyema wanandoa ama walio katika mahusiano kufika kwenye vituo vya afya ili kupata elimu juu ya matumizi sahihi ya uzazi wa mpango, kusaidia kuepuka madhara yanayoweza kujitokeza.</p>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_8_603abad7c1e80_rand td_block_template_1"><!-- /77344670/MTZ_article_728x90_1 -->
<div id='div-gpt-ad-1610715033371-0' style='width: 728px; height: 90px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1610715033371-0'); });
  </script>
</div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=MAKALA%3A+Zifahamu+njia+za+Uzazi+wa+Mpango+zinavyofanyakazi&url=https%3A%2F%2Fmtanzania.co.tz%2Fmakala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi%2F&via=Mtanzania">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/&amp;media=https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg&description=MAKALA%3A+Zifahamu+njia+za+Uzazi+wa+Mpango+zinavyofanyakazi">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi %0A%0A https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/&text=MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi">
                                        <div class="td-social-but-icon"><i class="td-icon-telegram"></i></div>
                                        <div class="td-social-but-text">Telegram</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://mtanzania.co.tz/wakulima-na-wafugaji-wavamia-eneo-la-misitu-na-ardhi-oevu-moyowosi-malagarasi/">Wakulima na wafugaji wavamia eneo la misitu na ardhi Oevu Moyowosi- Malagarasi</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://mtanzania.co.tz/halmashauri-ya-mwanga-yatekeleza-agizo-la-rais-magufuli/">Halmashauri ya Mwanga yatekeleza agizo la Rais Magufuli</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://mtanzania.co.tz/author/newhabari/">Mtanzania Digital</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Mtanzania Digital"></span><meta itemprop="datePublished" content="2021-02-27T14:08:55+00:00"><meta itemprop="dateModified" content="2021-02-27T14:08:56+03:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://mtanzania.co.tz/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mtanzania.co.tz/wp-content/uploads/2020/06/Header_Logo_Black.png"></span><meta itemprop="name" content="Mtanzania"></span><meta itemprop="headline " content="MAKALA: Zifahamu njia za Uzazi wa Mpango zinavyofanyakazi"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mtanzania.co.tz/wp-content/uploads/2021/02/0-13.jpg"><meta itemprop="width" content="560"><meta itemprop="height" content="340"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_9_603abad7c2758_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_9_603abad7c2758" ><script>var block_td_uid_9_603abad7c2758 = new tdBlock();
block_td_uid_9_603abad7c2758.id = "td_uid_9_603abad7c2758";
block_td_uid_9_603abad7c2758.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_9_603abad7c2758_rand","td_column_number":3,"live_filter_cur_post_id":102428,"live_filter_cur_post_author":"5","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_9_603abad7c2758_rand","tdc_css_class_style":"td_uid_9_603abad7c2758_rand_style"}';
block_td_uid_9_603abad7c2758.td_column_number = "3";
block_td_uid_9_603abad7c2758.block_type = "td_block_related_posts";
block_td_uid_9_603abad7c2758.post_count = "3";
block_td_uid_9_603abad7c2758.found_posts = "8155";
block_td_uid_9_603abad7c2758.header_color = "";
block_td_uid_9_603abad7c2758.ajax_pagination_infinite_stop = "";
block_td_uid_9_603abad7c2758.max_num_pages = "2719";
tdBlocksArray.push(block_td_uid_9_603abad7c2758);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_10_603abad7d61b6" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_9_603abad7c2758" href="#">RELATED ARTICLES</a><a id="td_uid_11_603abad7d61b9" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_9_603abad7c2758" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_9_603abad7c2758 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/prof-kitila-aongoza-ziara-ukaguzi-miradi-mfuko-wa-jimbo/" rel="bookmark" class="td-image-wrap" title="Prof. Kitila aongoza ziara ukaguzi miradi mfuko wa jimbo"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/90d14b51-7360-4e17-a6ef-c336718667dd-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/90d14b51-7360-4e17-a6ef-c336718667dd-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/90d14b51-7360-4e17-a6ef-c336718667dd-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Prof. Kitila aongoza ziara ukaguzi miradi mfuko wa jimbo"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/prof-kitila-aongoza-ziara-ukaguzi-miradi-mfuko-wa-jimbo/" rel="bookmark" title="Prof. Kitila aongoza ziara ukaguzi miradi mfuko wa jimbo">Prof. Kitila aongoza ziara ukaguzi miradi mfuko wa jimbo</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/halmashauri-ya-mwanga-yatekeleza-agizo-la-rais-magufuli/" rel="bookmark" class="td-image-wrap" title="Halmashauri ya Mwanga yatekeleza agizo la Rais Magufuli"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/hqdefault-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/hqdefault-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/hqdefault-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Halmashauri ya Mwanga yatekeleza agizo la Rais Magufuli"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/halmashauri-ya-mwanga-yatekeleza-agizo-la-rais-magufuli/" rel="bookmark" title="Halmashauri ya Mwanga yatekeleza agizo la Rais Magufuli">Halmashauri ya Mwanga yatekeleza agizo la Rais Magufuli</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mtanzania.co.tz/wakulima-na-wafugaji-wavamia-eneo-la-misitu-na-ardhi-oevu-moyowosi-malagarasi/" rel="bookmark" class="td-image-wrap" title="Wakulima na wafugaji wavamia eneo la misitu na ardhi Oevu Moyowosi- Malagarasi"><img width="218" height="150" class="entry-thumb" src="https://mtanzania.co.tz/wp-content/uploads/2021/02/d3e1c0f2-224e-42fa-8a10-14cb69d67589-218x150.jpg" srcset="https://mtanzania.co.tz/wp-content/uploads/2021/02/d3e1c0f2-224e-42fa-8a10-14cb69d67589-218x150.jpg 218w, https://mtanzania.co.tz/wp-content/uploads/2021/02/d3e1c0f2-224e-42fa-8a10-14cb69d67589-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Wakulima na wafugaji wavamia eneo la misitu na ardhi Oevu Moyowosi- Malagarasi"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mtanzania.co.tz/wakulima-na-wafugaji-wavamia-eneo-la-misitu-na-ardhi-oevu-moyowosi-malagarasi/" rel="bookmark" title="Wakulima na wafugaji wavamia eneo la misitu na ardhi Oevu Moyowosi- Malagarasi">Wakulima na wafugaji wavamia eneo la misitu na ardhi Oevu Moyowosi- Malagarasi</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_9_603abad7c2758" data-td_block_id="td_uid_9_603abad7c2758"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_9_603abad7c2758" data-td_block_id="td_uid_9_603abad7c2758"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/makala-zifahamu-njia-za-uzazi-wa-mpango-zinavyofanyakazi/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://mtanzania.co.tz/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='102428' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                                <!-- .no sidebar -->
                                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-14 ">
    <div class="td-container td-footer-bottom-full">
        <div class="td-pb-row">
            <div class="td-a-rec td-a-rec-id-footer_top  td_uid_12_603abad7d7121_rand td_block_template_1"><div class="a-single a-22"><div style="left:15%; position: fixed; text-align:center; bottom: 0px; width:100%; z-index:999;"> <a class="gofollow" data-track="MjIsMCwxLDYw" href="https://www.benkinisimbanking.crdbbank.co.tz/?utm_source=Mtanzania&utm_medium=Banner&utm_campaign=Benki%20ni%20SimBanking&utm_term=Mzigo%20Umeboreshwa" target="_blank"><img src="https://mtanzania.co.tz/wp-content/uploads/2021/02/970x70crdb.jpg" /></a> </div></div></div><div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://mtanzania.co.tz/"><img src="https://mtanzania.co.tz/wp-content/uploads/2020/06/footer_logo.png" alt="" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Gazeti la Mtanzania “Fikra yakinifu” ni gazeti Makini linalogusa maisha ya mamilioni ya watanzania wa rika na jinsia zote. Mtanzania ni gazeti la kitaifa la kila siku linajivunia rekodi ya kuwa huru na kuaminika kubeba Habari, Makala na chambuzi,siasa, uchumi, elimu, michezo na burudani zenye ajenda za watanzania katika mtizamo wa kitanzania. <div class="footer-email-wrap">Contact us: <a href="mailto:info@mtanzania.co.tz">info@mtanzania.co.tz</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/mtanzanianews" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/mtanzanianews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCyUoC43pwXFJo0itXbuVjJQ" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-main-container"><ul id="menu-main-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-4"><a href="http://mtanzania.co.tz/">Mwanzo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7"><a href="https://mtanzania.co.tz/category/kitaifa/">Kitaifa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6"><a href="https://mtanzania.co.tz/category/kimataifa/">Kimataifa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-8"><a href="https://mtanzania.co.tz/category/mikoani/">Mikoani</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-5"><a href="https://mtanzania.co.tz/category/kanda-ya-ziwa-2/">Kanda ya Ziwa</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-33"><a href="https://mtanzania.co.tz/category/zanzibar/">Zanzibar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39"><a href="https://mtanzania.co.tz/category/siasa/">Siasa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-40"><a href="https://mtanzania.co.tz/category/uchumi/">Biashara na Uchumi</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-35198"><a href="https://mtanzania.co.tz/category/afya/">Afya na Jamii</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://mtanzania.co.tz/category/sanaa/">Burudani</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-36"><a href="https://mtanzania.co.tz/category/michezo/">Michezo</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-37"><a href="https://mtanzania.co.tz/category/michezo/michezo-kimataifa/">Michezo Kimataifa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38"><a href="https://mtanzania.co.tz/category/michezo/michezo-kitaifa/">Michezo Kitaifa</a></li>
</ul>
</li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; New Habari (2006) Ltd. Haki zote zimeifadhiwa                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.8.2 (rara)
        Deploy mode: deploy
        
        uid: 603abad7d80f2
    -->

    <script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/mtanzania.co.tz\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-content/themes/newspaper/Newspaper/js/tagdiv_theme.min.js?ver=8.8.2' id='td-site-min-js'></script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b750612463a242d669bd59c5cf49d705' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://mtanzania.co.tz/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://mtanzania.co.tz/wp-content/themes/newspaper/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://mtanzania.co.tz/wp-content/themes/newspaper/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_603abad7d8225"></textarea>
						<div id="td_live_css_uid_1_603abad7d8225" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_603abad7d8225');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_603abad7d8225");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
<!-- advertising 6KOLVWKpeommMAdZ8d2FVs8iIZ7x9ZiyczcsfMltVJwwvUu4IICl1BIhw__Wjts44uF3HaRLGM42zuknHGm3nw==-->
							<script data-cfasync="false"  id="clevernt" type="text/javascript">
							 (function (document, window) {
                var c = document.createElement("script");
                c.type = "text/javascript"; c.async = !0; c.id = "CleverNTLoader39227";  c.setAttribute("data-target",window.name); c.setAttribute("data-callback","put-your-callback-macro-here");
                c.src = "//clevernt.com/scripts/45a5ac3be577ea6618a2afd792c2ca32.min.js?20200525=" + Math.floor((new Date).getTime());
                var a = !1;
                try {
                    a = parent.document.getElementsByTagName("script")[0] || document.getElementsByTagName("script")[0];
                } catch (e) {
                    a = !1;
                }
                a || ( a = document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]);
                a.parentNode.insertBefore(c, a);
            })(document, window);
                                </script>
                                <!-- end advertising -->
</body>
</html>